Project

Profile

Help

Task #6987

ERROR: Call to virDomainCreateWithFlags failed: internal error: Monitor path /var/lib/libvirt/qemu/release-143-debug-mariadb-101-debian_wheezy_libvirt-release-143-debug_maxscale.monitor too big for destination

Added by Alexander Kaluzhny about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
High
Assignee:
Timofey Turenko
Category:
mdbci testing
Sprint/Milestone:
Start date:
28.04.2016
Due date:
% Done:

0%

Estimated time:
Target branch:
Test scenario:

https://dev.osll.ru/issues/6987#note-3


Description

http://max-tst-01.mariadb.com:8089/job/run_test_matrix/backend=mariadb-10.1,box=debian_wheezy_libvirt/4/consoleFull

ERROR: An error occurred while executing multiple actions in parallel.
ERROR: Any errors that occurred are shown below.
ERROR:
ERROR: An error occurred while executing the action on the 'node1'
ERROR: machine. Please handle this error then try again:
ERROR:
ERROR: Chef never successfully completed! Any errors should be visible in the
ERROR: output above. Please fix your recipes so that they properly complete.
ERROR:
ERROR: An error occurred while executing the action on the 'maxscale'
ERROR: machine. Please handle this error then try again:
ERROR:
ERROR: There was an error talking to Libvirt. The error message is shown
ERROR: below:
ERROR:
ERROR: Call to virDomainCreateWithFlags failed: internal error: Monitor path /var/lib/libvirt/qemu/release-143-debug-mariadb-101-debian_wheezy_libvirt-release-143-debug_maxscale.monitor too big for destination
ERROR: Bringing up failed
ERROR: exit code 1
WARN: Checking for dead machines and checking Chef runs on machines
ERROR: Some machines are dead:
ERROR: maxscale


Related issues

Copied to [mdbci] Maria DB Continuous integration tool - Task #8067: Call to virDomainCreateWithFlags failed: internal error: Monitor path /var/lib/libvirt/qemu/domain-daily_maxscale_bsl_branch_run_test-224-develop-markusjm_galera_003/monitor.sock too big for destinationClosed28.04.2016

<a title="Actions" class="icon-only icon-actions js-contextmenu" href="#">Actions</a>

History

#1 Updated by Alexander Kaluzhny about 5 years ago

First possible problem is too long name for libvirt image (according to this post https://github.com/vagrant-libvirt/vagrant-libvirt/issues/545)
INFO: > maxscale: Creating domain with the following settings...
INFO: > maxscale: -- Name: release-143-debug-mariadb-101-debian_wheezy_libvirt-release-143-debug_maxscale
INFO: > maxscale: -- Domain type: kvm
INFO: > maxscale: -- Cpus: 1
INFO: > maxscale: -- Memory: 2048M
INFO: > maxscale: -- Management MAC:
INFO: > maxscale: -- Loader:
INFO: > maxscale: -- Base box: baremettle/debian-7.5
INFO: > maxscale: -- Storage pool: default
INFO: > maxscale: -- Image: /var/lib/libvirt/images/release-143-debug-mariadb-101-debian_wheezy_libvirt-release-143-debug_maxscale.img (40G)

#2 Updated by Alexander Kaluzhny about 5 years ago

  • Status changed from New to Active / In progress

#3 Updated by Alexander Kaluzhny about 5 years ago

Confirmed problem. Machine name is too long for libvirt provider (initially issue is due to folder's name where mdbci saves vagrant file is too long, beacuse libvirt build name from Vagrantfile's folder and node name)

Vagrant.configure(2) do |config|
config.vm.boot_timeout = 60
       config.vm.define "node1123456789876345678765432456765432345678765434567876543567876545678765456787656789" do |node1|
           config.ssh.pty = false
           node1.vm.box = "centos/7" 
           node1.vm.hostname = "node1" 
           node1.vm.synced_folder "../cnf", "/home/vagrant/cnf_templates", type: "rsync" 
           node1.vm.provider :libvirt do |qemu|
                      qemu.driver = "kvm" 
                      qemu.memory = 1024
              end
       end 
end

#4 Updated by Alexander Kaluzhny about 5 years ago

  • Test scenario updated (diff)

#5 Updated by Alexander Kaluzhny about 5 years ago

  • Status changed from Active / In progress to Review
  • Assignee changed from Alexander Kaluzhny to Mark Zaslavskiy

#6 Updated by Mark Zaslavskiy about 5 years ago

  • Priority changed from Normal to High

#7 Updated by Alexander Kaluzhny about 5 years ago

  • Test scenario updated (diff)

#8 Updated by Mark Zaslavskiy about 5 years ago

  • Status changed from Review to Testing
  • Assignee changed from Mark Zaslavskiy to Timofey Turenko

#9 Updated by Mark Zaslavskiy almost 5 years ago

  • Status changed from Testing to Active / In progress
  • Assignee changed from Timofey Turenko to Mark Zaslavskiy

#10 Updated by Mark Zaslavskiy almost 5 years ago

What solution can be proposed?

#11 Updated by Mark Zaslavskiy almost 5 years ago

  • Status changed from Active / In progress to New
  • Assignee changed from Mark Zaslavskiy to Alexander Kaluzhny

#12 Updated by Mark Zaslavskiy almost 5 years ago

  • Assignee changed from Alexander Kaluzhny to Mark Zaslavskiy

#13 Updated by Mark Zaslavskiy almost 5 years ago

  • Status changed from New to Active / In progress

#14 Updated by Mark Zaslavskiy almost 5 years ago

Decided to truncate names at run_test_matrix

#15 Updated by Mark Zaslavskiy almost 5 years ago

  • Status changed from Active / In progress to Testing
  • Assignee changed from Mark Zaslavskiy to Timofey Turenko

#16 Updated by Mark Zaslavskiy almost 5 years ago

  • Sprint/Milestone changed from 0.83 to 0.9

#17 Updated by Timofey Turenko almost 5 years ago

  • Status changed from Testing to Closed

solved by optimizing name in the Jenkins job. Closing

#18 Updated by Alexander Kaluzhny about 4 years ago

  • Copied to Task #8067: Call to virDomainCreateWithFlags failed: internal error: Monitor path /var/lib/libvirt/qemu/domain-daily_maxscale_bsl_branch_run_test-224-develop-markusjm_galera_003/monitor.sock too big for destination added

Also available in: Atom PDF