Project

Profile

Help

Task #7326

Errors during mdbci up libvirt_lite on maxscale-jenkins

Added by Mark Zaslavskiy almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Category:
mdbci features
Sprint/Milestone:
Start date:
01.08.2016
Due date:
% Done:

0%

Estimated time:
2:00 h
Target branch:
Test scenario:

1. Generate config for confs/libvirt_lite.json in test7326 folder.
2. ./mdbci up test7326

Expected result:
no errors in log


Description

1. Up libvirt_lite

2. In the end of a output

ERROR: /home/vagranttest/mdbci_zaslavskiy/core/network.rb:186:in `rescue in getIpWrapper'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:182:in `getIpWrapper'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:174:in `getNetwork'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:305:in `block in collectConfigurationNetworkInfo'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:303:in `each'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:303:in `collectConfigurationNetworkInfo'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:290:in `block in printConfigurationNetworkInfoToFile'
/usr/lib/ruby/1.9.1/open-uri.rb:35:in `open'
/usr/lib/ruby/1.9.1/open-uri.rb:35:in `open'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:289:in `printConfigurationNetworkInfoToFile'
/home/vagranttest/mdbci_zaslavskiy/core/session.rb:772:in `up'
/home/vagranttest/mdbci_zaslavskiy/core/session.rb:451:in `commands'
./mdbci:128:in `<main>'
ERROR: Incorrect node

History

#1 Updated by Mark Zaslavskiy almost 5 years ago

INFO: Running [vagrant ssh node0 -c "whoami"] on libvirt_lite_1/node0
Connection to 192.168.121.38 closed.
INFO: Running [vagrant ssh node0 -c "hostname"] on libvirt_lite_1/node0
Connection to 192.168.121.38 closed.
INFO: Load configuration nodes from vagrant status ...
INFO: getInterfaceBoxIp attempt
Connection to 192.168.121.65 closed.
INFO: bash: /sbin/ifconfig: Нет такого файла или каталога
INFO: 1
ERROR: invalid byte sequence in US-ASCII
/usr/lib/ruby/1.9.1/scanf.rb:459:in `sub!'
/usr/lib/ruby/1.9.1/scanf.rb:459:in `match'
/usr/lib/ruby/1.9.1/scanf.rb:548:in `block in match'
/usr/lib/ruby/1.9.1/scanf.rb:545:in `each'
/usr/lib/ruby/1.9.1/scanf.rb:545:in `each_with_index'
/usr/lib/ruby/1.9.1/scanf.rb:545:in `match'
/usr/lib/ruby/1.9.1/scanf.rb:725:in `scanf'
/home/vagranttest/mdbci_zaslavskiy/core/node.rb:53:in `getInterfaceBoxIp'
/home/vagranttest/mdbci_zaslavskiy/core/node.rb:74:in `getIp'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:183:in `getIpWrapper'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:174:in `getNetwork'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:307:in `block in collectConfigurationNetworkInfo'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:305:in `each'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:305:in `collectConfigurationNetworkInfo'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:292:in `block in printConfigurationNetworkInfoToFile'
/usr/lib/ruby/1.9.1/open-uri.rb:35:in `open'
/usr/lib/ruby/1.9.1/open-uri.rb:35:in `open'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:291:in `printConfigurationNetworkInfoToFile'
/home/vagranttest/mdbci_zaslavskiy/core/session.rb:772:in `up'
/home/vagranttest/mdbci_zaslavskiy/core/session.rb:451:in `commands'
./mdbci:128:in `<main>'
ERROR: /home/vagranttest/mdbci_zaslavskiy/core/network.rb:188:in `rescue in getIpWrapper'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:182:in `getIpWrapper'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:174:in `getNetwork'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:307:in `block in collectConfigurationNetworkInfo'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:305:in `each'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:305:in `collectConfigurationNetworkInfo'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:292:in `block in printConfigurationNetworkInfoToFile'
/usr/lib/ruby/1.9.1/open-uri.rb:35:in `open'
/usr/lib/ruby/1.9.1/open-uri.rb:35:in `open'
/home/vagranttest/mdbci_zaslavskiy/core/network.rb:291:in `printConfigurationNetworkInfoToFile'
/home/vagranttest/mdbci_zaslavskiy/core/session.rb:772:in `up'
/home/vagranttest/mdbci_zaslavskiy/core/session.rb:451:in `commands'
./mdbci:128:in `<main>'
ERROR: Incorrect node

#2 Updated by Mark Zaslavskiy almost 5 years ago

  • Status changed from New to Active / In progress

#3 Updated by Mark Zaslavskiy almost 5 years ago

  • Estimated time set to 2:00 h

#4 Updated by Mark Zaslavskiy almost 5 years ago

  • Test scenario updated (diff)

Problem was caused by missconfiguration of a DNS servers.

#5 Updated by Mark Zaslavskiy almost 5 years ago

  • Status changed from Active / In progress to Closed

Also available in: Atom PDF