Project

Profile

Help

Task #8222

INFO: Node IP is not valid!

Added by Mark Zaslavskiy about 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
High
Assignee:
Timofey Turenko
Category:
-
Sprint/Milestone:
Start date:
20.04.2017
Due date:
% Done:

0%

Estimated time:
Target branch:
Test scenario:

https://github.com/mariadb-corporation/mdbci/pull/11/files

Added fix, which will try 10 times to get network data with 5 seconds delay between attmpts.

Testing rebuild failed build using branch with fixes


Description

http://max-tst-01.mariadb.com:8089/view/All/job/run_test/1747/consoleFull

INFO:  Generating johan-develop_network_settings file
INFO: Load configuration nodes from vagrant status ...
The provider for this Vagrant-managed machine is reporting that it
is not yet ready for SSH. Depending on your provider this can carry
different meanings. Make sure your machine is created and running and
try again. Additionally, check the output of `vagrant status` to verify
that the machine is in the state that you expect. If you continue to
get this error message, please view the documentation for the provider
you're using.
INFO: Node IP is not valid!
WARN: IP address is not received!
ERROR: vagrant ssh get IP command returned non-zero exit code: (1)
ERROR: /home/vagrant/mdbci/core/network.rb:191:in `rescue in getIpWrapper'
/home/vagrant/mdbci/core/network.rb:187:in `getIpWrapper'
/home/vagrant/mdbci/core/network.rb:179:in `getNetwork'
/home/vagrant/mdbci/core/network.rb:312:in `block in collectConfigurationNetworkInfo'
/home/vagrant/mdbci/core/network.rb:310:in `each'
/home/vagrant/mdbci/core/network.rb:310:in `collectConfigurationNetworkInfo'
/home/vagrant/mdbci/core/network.rb:288:in `block in printConfigurationNetworkInfoToFile'
/usr/lib/ruby/1.9.1/open-uri.rb:35:in `open'
/usr/lib/ruby/1.9.1/open-uri.rb:35:in `open'
/home/vagrant/mdbci/core/network.rb:287:in `printConfigurationNetworkInfoToFile'
/home/vagrant/mdbci/core/session.rb:776:in `up'
/home/vagrant/mdbci/core/session.rb:453:in `commands'
./mdbci:133:in `<main>'
ERROR: Incorrect node
Error creating configuration
Failed to create VMs, exiting
+ echo 1

History

#1 Updated by Mark Zaslavskiy about 4 years ago

  • Assignee changed from Mark Zaslavskiy to Alexander Kaluzhny

Fix idea - use standart reup approach

#2 Updated by Mark Zaslavskiy almost 4 years ago

1. Do grep at build logs by error
2. What command "ERROR: vagrant ssh get IP command returned non-zero exit code: (1)" ? What does exit code =1 means?
3. Add link to github for failing place

#3 Updated by Alexander Kaluzhny almost 4 years ago

  • Status changed from New to Active / In progress

#4 Updated by Alexander Kaluzhny almost 4 years ago

  • Status changed from Active / In progress to Review
  • Assignee changed from Alexander Kaluzhny to Mark Zaslavskiy

#5 Updated by Alexander Kaluzhny almost 4 years ago

  • Status changed from Review to Active / In progress
  • Assignee changed from Mark Zaslavskiy to Alexander Kaluzhny

#6 Updated by Mark Zaslavskiy almost 4 years ago

  • Status changed from Active / In progress to Testing
  • Assignee changed from Alexander Kaluzhny to Timofey Turenko
  • Test scenario updated (diff)

#7 Updated by Alexander Kaluzhny almost 4 years ago

  • Test scenario updated (diff)

#8 Updated by Timofey Turenko almost 4 years ago

  • Status changed from Testing to Closed

Also available in: Atom PDF