Project

Profile

Help

Bug #8563

on max-tst02 server generation fails

Added by Ilfat Kinyaev over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Ilfat Kinyaev
Category:
-
Sprint/Milestone:
Start date:
16.08.2017
Due date:
% Done:

100%

Estimated time:
1:00 h
Target branch:
Test scenario:

Description

Error:

/home/vagrant/mdbci/mdbci --override --template /home/vagrant/vms/centos_7_libvirt-build-13055.json generate centos_7_libvirt-build-13055
 INFO:  MariaDb CI CLI
 INFO:  mdbci called with: ["generate", "centos_7_libvirt-build-13055"]
 INFO:  Checking this machine configuration requirments
 INFO:  .....NOT IMPLEMENTED YET
 INFO:  Load Boxes from /home/vagrant/mdbci/BOXES
 INFO:  Loaded boxes: 45
 INFO:  Load AWS config from /home/vagrant/mdbci/aws-config.yml
 INFO:  Load Repos from /home/vagrant/mdbci/repo.d
 INFO:  Looking up for repos /home/vagrant/mdbci/repo.d
 INFO:  Loaded repos: 752
{"hostname"=>"default", "box"=>"centos_7_libvirt"}
 INFO:  /home/vagrant/mdbci/recipes/cookbooks/
 INFO:  Global cookbook_path = /home/vagrant/mdbci/recipes/cookbooks/
 INFO:  Nodes provider = libvirt
ERROR:  /home/vagrant/mdbci/core/generator.rb:538:in ``'
/home/vagrant/mdbci/core/generator.rb:538:in `generateKeypair'
/home/vagrant/mdbci/core/generator.rb:576:in `generate'
/home/vagrant/mdbci/core/session.rb:522:in `generate'
/home/vagrant/mdbci/core/session.rb:453:in `commands'
/home/vagrant/mdbci/mdbci:141:in `<main>'
ERROR:  No such file or directory - aws
+ echo 'starting VM for build'
starting VM for build
+ /home/vagrant/mdbci/mdbci up --attempts=1 centos_7_libvirt-build-13055
 INFO:  MariaDb CI CLI
 INFO:  mdbci called with: ["up", "centos_7_libvirt-build-13055"]
 INFO:  Checking this machine configuration requirments
 INFO:  .....NOT IMPLEMENTED YET
 INFO:  Load Boxes from /home/vagrant/mdbci/BOXES
 INFO:  Loaded boxes: 45
 INFO:  Load AWS config from /home/vagrant/mdbci/aws-config.yml
 INFO:  Load Repos from /home/vagrant/mdbci/repo.d
 INFO:  Looking up for repos /home/vagrant/mdbci/repo.d
 INFO:  Loaded repos: 752
 INFO:  Node isn't specified in centos_7_libvirt-build-13055
ERROR:  /home/vagrant/mdbci/core/session.rb:603:in `read'
/home/vagrant/mdbci/core/session.rb:603:in `up'
/home/vagrant/mdbci/core/session.rb:455:in `commands'
/home/vagrant/mdbci/mdbci:141:in `<main>'
ERROR:  No such file or directory @ rb_sysopen - centos_7_libvirt-build-13055/template
+ '[' 1 '!=' 0 ']'
+ echo 'Error starting VM'
Error starting VM

===============================
Assumptions:
- AWS not properly installed aws : run setup_aws.sh from repo;
- something else.

History

#1 Updated by Ilfat Kinyaev over 3 years ago

  • Description updated (diff)

#2 Updated by Ilfat Kinyaev over 3 years ago

Waiting results of http://127.0.0.1:8089/job/build/13057/
(rebuild of 13055)

#3 Updated by Ilfat Kinyaev over 3 years ago

  • Description updated (diff)

#4 Updated by Ilfat Kinyaev over 3 years ago

  • Status changed from New to Closed
  • % Done changed from 0 to 100

#5 Updated by Ilfat Kinyaev over 3 years ago

Build done successfully.

Also available in: Atom PDF